yash-git/PKGBUILD

36 lines
684 B
Bash

# Maintainer: Jef Roosens
pkgbase='yash-git'
pkgname='yash-git'
pkgver=2.25.r1478.g2972e9a3
pkgrel=1
pkgdesc='Yash, yet another shell, is a POSIX-compliant command line shell written in C99. (Development version)'
arch=('x86_64')
url='https://yash.osdn.jp'
license=('GPL2')
depends=('ncurses')
makedepends=('git' 'asciidoc')
source=("${pkgname}::git+https://github.com/magicant/yash#branch=trunk")
md5sums=('SKIP')
options=(lto)
pkgver() {
git -C "${pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${pkgname}"
./configure --prefix='/usr'
make
}
package() {
cd "${pkgname}"
make install DESTDIR="${pkgdir}"
}