34 lines
831 B
Bash
34 lines
831 B
Bash
# Maintainer: Jef Roosens
|
|
|
|
_pkgname='lander'
|
|
pkgname='lander-git'
|
|
pkgdesc='URL shortener, pastebin & file-sharing service, written from the ground up in C (development version)'
|
|
pkgver=0.1.0.r76.ge42004d
|
|
pkgrel=1
|
|
arch=('x86_64')
|
|
|
|
url='https://git.rustybever.be/Chewing_Bever/lander'
|
|
license=('MIT')
|
|
|
|
makedepends=('gcc' 'make')
|
|
depends=('glibc' 'libmagic.so=1-64' 'libcurl.so=4-64')
|
|
|
|
source=("${_pkgname}::git+https://git.rustybever.be/Chewing_Bever/lander#branch=dev")
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
|
|
}
|
|
|
|
build() {
|
|
cd "${_pkgname}"
|
|
|
|
make
|
|
make -C landerctl
|
|
}
|
|
|
|
package() {
|
|
install -Dm755 "${_pkgname}/build/lander" "${pkgdir}/usr/bin/lander"
|
|
install -Dm755 "${_pkgname}/landerctl/build/landerctl" "${pkgdir}/usr/bin/landerctl"
|
|
}
|