75 lines
2.8 KiB
Bash
75 lines
2.8 KiB
Bash
# Maintainer: Rick van Lieshout <info@rickvanlieshout.com>
|
|
|
|
pkgname=tidal-hifi-git
|
|
pkgrel=2
|
|
pkgver=4.3.1.r1.gcd2a068
|
|
pkgdesc="The web version of listen.tidal.com running in electron with hifi support thanks to widevine. If the install fails use nvm to temporarily downgrade npm"
|
|
arch=(x86_64)
|
|
url="https://github.com/Mastermindzh/tidal-hifi"
|
|
license=("custom:MIT")
|
|
depends=(libxss nss gtk3 libxcrypt-compat)
|
|
makedepends=(git nvm)
|
|
provides=(tidal-hifi)
|
|
conflicts=(tidal-hifi)
|
|
|
|
source=("git+https://github.com/Mastermindzh/tidal-hifi.git"
|
|
"tidal-hifi.desktop"
|
|
"tidal-hifi.xml")
|
|
sha512sums=('SKIP'
|
|
'20dc16dfd79cd00686b29bc621c64568b6557d73da5b7c1fba7dee0277784cc6f133520ca55d83fb878c3e5cc6734b6fd1b47502366a8907113625ce4e362bbc'
|
|
"e06fce55c2d9fcaeff514b97e8b003dca4c1a0aa8c8e14c3e3b99febbc2e8af7402d2e2009147f3f57a9b6447fafd23dd69e7b4de63cf43c5d67825836ebecb5")
|
|
|
|
pkgver() {
|
|
cd "${srcdir}/${pkgname%-git}" || exit
|
|
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
|
|
}
|
|
|
|
prepare() {
|
|
# This PKGBUILD is meant to run in a build container, so we can do this
|
|
# every time.
|
|
source /usr/share/nvm/init-nvm.sh
|
|
|
|
cd "${srcdir}/${pkgname%-git}" || exit
|
|
|
|
# use correct nodejs/npm versions
|
|
nvm install lts/gallium
|
|
nvm use lts/gallium
|
|
|
|
# install build dependencies
|
|
npm install
|
|
}
|
|
|
|
build() {
|
|
# Each function needs this separately
|
|
source /usr/share/nvm/init-nvm.sh
|
|
|
|
cd "${srcdir}/${pkgname%-git}" || exit
|
|
|
|
# We are not using the systems Electron as we need castlab's Electron.
|
|
npm run build-arch
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname%-git}" || exit
|
|
|
|
install -d "${pkgdir}/opt/tidal-hifi/" "${pkgdir}/usr/bin" "${pkgdir}/usr/share/doc" "${pkgdir}/usr/share/licenses"
|
|
|
|
cp -r dist/linux-unpacked/* "${pkgdir}/opt/tidal-hifi/"
|
|
chmod +x "${pkgdir}/opt/tidal-hifi/tidal-hifi"
|
|
|
|
ln -s "/opt/tidal-hifi/tidal-hifi" "${pkgdir}/usr/bin/tidal-hifi"
|
|
|
|
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/pixmaps/tidal-hifi.png"
|
|
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/${pkgname%-git}/tidal-hifi.png"
|
|
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
|
|
install -Dm 644 "${srcdir}/tidal-hifi.desktop" "${pkgdir}/usr/share/applications/tidal-hifi.desktop"
|
|
install -Dm 644 "${srcdir}/tidal-hifi.xml" "${pkgdir}/usr/share/mime/packages/tidal-hifi.xml"
|
|
|
|
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
|
|
install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
install -Dm 644 "build/icon.png" "${pkgdir}/usr/share/icons/hicolor/0x0/apps/tidal-hifi.png"
|
|
|
|
ln -s "/opt/tidal-hifi/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.electron.txt"
|
|
ln -s "/opt/tidal-hifi/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"
|
|
}
|